Issues in IE

Jul 16, 2015 at 3:26 PM
I have some rtsp cameras using vlc_trancode. The videos can be seen fine in Chrome and Firefox, but it won't show in IE.

Any help is appreciated.
Coordinator
Jul 16, 2015 at 3:37 PM
My best guess is that it is trying to pull an mjpeg stream because it thinks you are on the same LAN with the server. IE doesn't support MJPEG last I checked. Add a parameter to the URL, refresh=0 to force it to use refreshing jpeg mode instead of mjpeg. e.g. /porch.cam?refresh=0
Jul 18, 2015 at 12:35 AM
I fixed the problem using the following code:

<!DOCTYPE html>
<html>
<head>
    <title>Video Title</title>
    <meta charset="UTF-8">
</head>
<body>

    <!--- BEGIN PLAYER --->

    <!-- webbot bot="HTMLMarkup" startspan ---->
    <![if !IE]>

    <object ID="MediaPlayer" WIDTH="640" height="370" CLASSID="CLSID:22D6f312-B0F6-11D0-94AB-0080C74C7E95" STANDBY="Loading Windows Media Player components..." TYPE="application/x-oleobject" CODEBASE="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=6,4,7,1112">

        <param name="autoStart" value="True">

        <param name="filename" value="http://servername/stream.mjpg">  

        <param NAME="ShowControls" VALUE="False">

        <param NAME="ShowStatusBar" VALUE="False">

        <embed TYPE="application/x-mplayer2" SRC="http://servername/stream.mjpg" NAME="MediaPlayer" WIDTH="640" height="370" autostart="1" showcontrols="0">

        </embed>
    </object>

    <![endif]> 

    <!--[if IE]>
<object classid="clsid:9BE31822-FDAD-461B-AD51-BE1D1C159921" codebase="http://downloads.videolan.org/pub/videolan/vlc/latest/win32/axvlc.cab" width="640" height="360" id="vlc" events="True">
    <param name="Src" value="http://servername/stream.mjpg"></param>
    <param name="ShowDisplay" value="True" ></param>
    <param name="AutoLoop" value="no"></param>
    <param name="AutoPlay" value="yes"></param>
    <embed type="application/x-google-vlc-plugin" name="vlcfirefox" autoplay="yes" loop="no" width="640" height="360" target="http://servername/stream.mjpg"></embed>
</object>         
     <![endif]-->         

</body>
</html>
Marked as answer by tropicalman59 on 7/17/2015 at 5:35 PM